Users are being shown as unverified erroneously
Incident Report for Valiu
Resolved
We have fixed the issue and our systems are now back to normal
Posted Oct 11, 2021 - 19:31 UTC
Investigating
Our team has identified the issue and is working on a fix.
Posted Oct 11, 2021 - 14:16 UTC